× Willkommen im Forum 107!

Hier dürft ihr all die Experten zum R107 SL und C107 SLC alles fragen und werdet fachkundige Antworten erhalten.

560 SL - Leerlaufsteuergerät (N8) zeitweise ohne Funktion

  • Quickbiker2012
  • Quickbiker2012s Avatar Autor
  • Offline
  • Senior
  • Senior
  • Americas (USA/CAN)
  • 560 SL 107.048 1987
Mehr
12 Jun 2021 21:27 #277288
von Quickbiker2012 Americas (USA/CAN) 560 SL 107.048 1987
Hallo zusammen,

seit etwa zwei Wochen habe ich verstärkt Probleme mit dem Leerlaufsteuergerät. Leider ist der Fehler nicht reproduzierbar :-(

Nachdem ich eine weile Gefahren bin und den Motor abstelle ist nach dem erneuten Anlassen die Leerlaufregelung außer Funktion und damit dreht der Motor im Leerlauf ~ 1.600 U/Min. Der Fehler ist bisher noch nie beim ersten Anlassen (kalt) aufgetreten sondern immer nur nach dem Anlassen wenn ich den Motor nach einiger Zeit abstelle und wieder anlasse. Manchmal verschwindet der Fehler dann beim Fahren, manchmal auch erst wenn der SL eine Zeitlang gestanden hat. Was mich an dem ganzen Wundert ist, dass der Fehler noch kein eines mal bei schon laufendem Motor aufgetreten ist, sondern immer nur beim Anlassen. Funktioniert die Regelung beim Anlassen fällt sie auch nicht aus.

Ein paar Sachen konnte ich prüfen / ausschließen - ist leider nicht so einfach bei Fehlern die nur ab uns an mal auftreten:
  • Wenn der Fehler auftritt liegt am Leerlaufsteller kein Signal mehr an - > also kann das nur vom Steuergerät oder der Verkabelung kommen 
  • Die diskreten Bauteile im Steuergerät habe ich wegen eventueller kalter Lötstellen nachgelötet, das hat nichts gebracht
  • An die SMD Huckepackplatine traue ich mich (noch) nicht ran da diese mit irgendeinem etwas klebrigen beschichtet ist
  • Das ÜSR kann ich eigentlich ausschließen, da die KE Jetronic funktioniert wenn der Fehler auftritt (Schubabschaltung funktioniert) und die ABS Kontrollleuchte aus bleibt
Als nächstes würde ich mir einen Testadapter bauen damit ich am Steuergerät direkt Messen kann ob eines der Eingangssignale fehlt / wegfällt und das ÜSR ausreichend Spannung liefert. Wie gesagt stutzig macht mich dass der Fehler nur im Zusammenhang mit dem Anlassvorgang auftritt und dann dableibt aber nie "einfach so" auftritt. In der WIS und im Schaltplan habe ich nichts gefunden dass darauf hindeutet, dass beim Anlassen irgendwas passiert dass die Leerlaufregelung überhaupt erst aktiviert.

Hat jemand on Euch noch eine Idee - leider habe ich kein Ersatzsteuergerät damit ich testen kann ob es das Steuergerät ist oder ob eines der Eingangssignale wegfällt.

Gruß,
Ralf

P.S.: Da es mir von Natur her wehtut mit einem Auto mit 1.600 U/Min Leerlaufdrehzahl herumzufahren, es gegen den Motor zum Stillstand abbremsen muss, mir das Getriebe jedes mal leidtut wenn ich auf D oder R Schalte und die 1.600 genau an der Grenze der Schubabschaltung sind habe ich mir für wirklich kleines Geld einen PWM Steller gekauft (www.amazon.de/gp/product/B07XTFLCWN) mit dem ich den Leerlaufsteller manuell ansteuern kann falls das Steuergerät ausfällt. Der Aufbau ist wirklich simpel - das Platinchen in ein Kästchen einbauen, den Eingang mit dem Zigarettenanzünder verbinden und den Ausgang mit dem Prallplattensteller - dann kann man mit dem Poti die Leerlaufdrehzahl einstellen. Da die Platine auch für Moren geeignet ist hat sie auch eine Löschdiode und damit auch für den Leerlaufsteller geeignet. Das ist glaube ich auch die perfekte Lösung wenn man eine konstante und definierte Drehzahl z.B. zum Einstellen des Stauschscheibenpotis benötigt. Das sollte zumindest bei allen MOPF V8 funktionieren.

 

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Chromix
  • Chromixs Avatar
  • Offline
  • Premium
  • Premium
  • Americas (USA/CAN)
  • 560 SL 107.048 1986
  • Hofrat
Mehr
12 Jun 2021 22:24 #277292
von Chromix Americas (USA/CAN) 560 SL 107.048 1986
Hallo Ralf,

das Leerlaufsteuergerät hat auch einen Eingang, an dem es ein Signal vom Zündschloß bekommt, wenn Du den Schlüssel auf Start drehst. Da Du schreibst, daß der Fehler nur im Zusammenhang mit dem Anlassen auftritt, würde ich mal überprüfen, ob dieses Signal korrekt ist, also nur beim Starten 12 V anliegt.
Danach dann, ob das Steuergerät überhaupt mit Spannung versorgt wird, sonst würde es natürlich auch kein Signal mehr an den LLS liefern.
Und dann, ob der Eingang, der vom Leerlaufkontakt kommt, plausible Werte hat und dann der RPM Eingang.
Das Steuergerät bekommt noch mehr Eingangssignale, aber bei denen kann ich mir kaum vorstellen, daß sie zu einem Totalausfall des Signals für den LLS führen.
Übrigens, coole Idee mit dem PWM-Steller - da hätte mir auch das Getriebe leid getan.

Hälsningar,
Lutz

Alles ist noch niemals vorgekommen - bis es zum ersten Mal passiert.
Folgende Benutzer bedankten sich: Quickbiker2012

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Dr-DJet
  • Dr-DJets Avatar
  • Offline
  • Moderator
  • Moderator
  • Schweiz
  • 450 SL 107.044 1973
Mehr
12 Jun 2021 23:55 #277294
von Dr-DJet Schweiz 450 SL 107.044 1973
Hallo Ralf,

ich würde da in der Tat auch erst mal nachsehen, was die Spannung am Eingang des LLSG macht. Das LLSG hat zwar noch eine ganze Reihe anderer Eingänge, aber die 1600/min sollten von fehlender Spannung oder interner Fehlfunktion herrühren. Da das aber offensichtlich nur beim Anlassen passiert, deutet das auf kein thermisches Problem des LLSG hin.

Schönes Teil der PWM Steller.

Viele Schraubergrüße - best regards, Volker alias Dr-DJet und K-Jet Forscher, Admin und Betreiber dieser Webseite
Alles über D-Jetronic und Zündung auf jetronic.org

Dieses Bild ist für Gäste verborgen.
Bitte anmelden oder registrieren um das Bild zu sehen.


Folgende Benutzer bedankten sich: Quickbiker2012

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Quickbiker2012
  • Quickbiker2012s Avatar Autor
  • Offline
  • Senior
  • Senior
  • Americas (USA/CAN)
  • 560 SL 107.048 1987
Mehr
13 Jun 2021 01:09 #277295
von Quickbiker2012 Americas (USA/CAN) 560 SL 107.048 1987
Hallo Lutz,

Du hast recht - die Klemme 50 vom Zündschloss hatte ich so gar nicht auf dem Schirm da der Anschluss in der WIS mit Startsperr- / Rückfahrschalter bezeichnet. Der hat aber wahrscheinlich drei Funktionen: Liegen +12V an (=Anlassen) deaktiviert das LLSG wahrscheinlich die Regelung um den Steller maximal zu öffnen. In N oder P liegt durch den Magnetschalter am Anlasser Masse an (= Normale Leerlaufdrehzahl), bei D oder R ist der Anschluss offen (= reduzierte Drehzahl). Das könnte auf einen internen Fehler im LLSG hindeuten wenn die Spannungen sonst da sind - mal schauen ob ich da was identifizieren kann - wahrscheinlich ist das aber auf der Huckepack SMD Platine 

Dieses Bild ist für Gäste verborgen.
Bitte anmelden oder registrieren um das Bild zu sehen.

 Dank des PWM Stellers kann ich das ja in Ruhe testen und trotzdem das schöne Wetter offen (und fahrend) genießen 

Dieses Bild ist für Gäste verborgen.
Bitte anmelden oder registrieren um das Bild zu sehen.



Volker, an ein grundsätzliches thermisches Problem glaube ich auch nicht, vielleicht ist da aber ein Bauteil oder eine Lötstelle rund um die Schaltung an der Klemme 50 gerade so am Rande der Toleranz. Das ganze Tritt zwar nur beim Anlassen auf, dafür aber immer erst dann wenn das LLSG schon eine Weile im Betrieb war.

Zum PWM Steller - das einzige was mich da momentan noch stört ist - der Leerlaufsteller reagiert sehr fein auf Änderungen im Signal. Mit dem Poti ist das ein bisschen Fummelig (zwischen 1000 U/Min und Motor aus liegt ne viertel Umdrehung) geht aber. Vielleicht finde ich da noch einen Trick den PWM Steller zu modifizieren damit das etwas feiner geht.

Danke Euch und gute Nacht :-)
Ralf

 

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • citroen
  • Offline
  • Senior
  • Senior
  • Americas (USA/CAN)
  • 560 SL 107.048 1986
Mehr
13 Jun 2021 07:55 - 13 Jun 2021 07:57 #277297
von citroen Americas (USA/CAN) 560 SL 107.048 1986
Moin Ralf,
es gibt Drehknöpfe die innenliegend noch ein Getriebe haben
dh. eine Umdrehung Poti gleich 10? Umdrehungen Drehknopf.
Gruß aus Hamburg, Rainer
Letzte Änderung: 13 Jun 2021 07:57 von citroen. Grund: Erweiterung

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Dr-DJet
  • Dr-DJets Avatar
  • Offline
  • Moderator
  • Moderator
  • Schweiz
  • 450 SL 107.044 1973
Mehr
13 Jun 2021 10:26 #277299
von Dr-DJet Schweiz 450 SL 107.044 1973
Hallo Ralf,

so was gibt es auch mit digitaler Einstellung der PWM : www.amazon.de/Drehzahlregler-Gleichstrom...zeige/dp/B07QNVC93Z/

Viele Schraubergrüße - best regards, Volker alias Dr-DJet und K-Jet Forscher, Admin und Betreiber dieser Webseite
Alles über D-Jetronic und Zündung auf jetronic.org

Dieses Bild ist für Gäste verborgen.
Bitte anmelden oder registrieren um das Bild zu sehen.


Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Quickbiker2012
  • Quickbiker2012s Avatar Autor
  • Offline
  • Senior
  • Senior
  • Americas (USA/CAN)
  • 560 SL 107.048 1987
Mehr
13 Jun 2021 23:42 #277318
von Quickbiker2012 Americas (USA/CAN) 560 SL 107.048 1987
Hallo Volker,

die hatte ich auch gesehen, ich bin aber eher ein haptischer Mensch :-) und brauche einen Knopf zum Anfassen. Da das Tastverhältnis zwischen kaltem und warmem Motor mehrmals angepasst werden muss fand ich das mit einem Poti besser, das kann man auch an der Ampel mal schnell verstellen. Für Test und Einstellzwecke ist das digitale auf jeden Fall besser geeignet.

Rainer,
meine Ungeduld hat jetzt zugeschlagen (10-Gang Poti hatte ich kein passendes da) und hab noch ein zweites Poti in Reihe geschaltet. Kann damit den Regelbereich begrenzen - momentan auf max. 60% D.h. ich hab jetzt knapp ne dreiviertel Umdrehung, das geht deutlich besser und hat den Vorteil dass ich den Motor nicht mehr abwürgen kann - ist mir vorher schon ein paar mal an der Ampel passiert 

Dieses Bild ist für Gäste verborgen.
Bitte anmelden oder registrieren um das Bild zu sehen.

 und damit bin ich wahrscheinlich einiger der Wenigen die ein Auto mit Automatik an der Ampel abwürgen :-)

Ich werde Euch über die weiteren Ergebnisse meiner Analyse auf dem Laufenden halten.

Bis dann und gute Nacht,
Ralf

 

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • PanTau
  • PanTaus Avatar
  • Offline
  • Elite
  • Elite
  • Standard (Europa)
  • 500 SLC 107.026 1980
Mehr
07 Jul 2021 15:34 #278746
von PanTau Standard (Europa) 500 SLC 107.026 1980

Hallo Volker,

vielen Dank..........
Ralf's PWM Ansteuerung als Ersatz für einen defekten Leerlaufsteller werde ich auf jeden Fall nachbauen - und dies für weniger als 5 €. 
.............
Herzlichen Dank und liebe Grüße
Michael

 


PWM-Bausatz für einen Leerlaufsteller? sehr interessant! Wer hat das erfunden? 
Bin sehr neugierig!
 

VG
Frank

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • lumitz
  • lumitzs Avatar
  • Offline
  • Frischling
  • Frischling
  • 380 SL USA 107.045 1981, 420 SL 107.047 1986, 560 SL 107.048 1989
Mehr
07 Jul 2021 18:44 #278765
von lumitz 380 SL USA 107.045 1981, 420 SL 107.047 1986, 560 SL 107.048 1989
Hallo Frank,

ich nehme an, dass Du Dich am Wort Leerlaufsteller störst. Gemeint war die Ansteuerung des Leerlaufstellers bei defektem Leerlaufsteuergerät. Aber Du kennst sicherlich Ralfs Beitrag im Forum.

Immer noch neugierig, dann kann Ralf sicherlich weiterhelfen.

Gruß

Michael

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Dr-DJet
  • Dr-DJets Avatar
  • Offline
  • Moderator
  • Moderator
  • Schweiz
  • 450 SL 107.044 1973
Mehr
07 Jul 2021 20:47 #278773
von Dr-DJet Schweiz 450 SL 107.044 1973
Hallo Frank,

der Ralf hat als Provisorium einen PWM Steller mit Poti als temporäre manuelle Lösung ersetzt, da sein Steuergerät defekt ist.

Viele Schraubergrüße - best regards, Volker alias Dr-DJet und K-Jet Forscher, Admin und Betreiber dieser Webseite
Alles über D-Jetronic und Zündung auf jetronic.org

Dieses Bild ist für Gäste verborgen.
Bitte anmelden oder registrieren um das Bild zu sehen.


Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Quickbiker2012
  • Quickbiker2012s Avatar Autor
  • Offline
  • Senior
  • Senior
  • Americas (USA/CAN)
  • 560 SL 107.048 1987
Mehr
08 Jul 2021 01:31 #278792
von Quickbiker2012 Americas (USA/CAN) 560 SL 107.048 1987
Hallo Zusammen,

ja genau, es geht um eine manuelle Lösung für mein Problem mit dem Steuergerät. Der Leerlaufsteller ist in Ordnung. Dem Fehler bin ich leider immer noch nicht näher gekommen. Immer wenn ich alle Messgeräte da habe tritt der Fehler nicht auf, ausgebaut konnte ich ihn auch noch nicht simulieren 

Dieses Bild ist für Gäste verborgen.
Bitte anmelden oder registrieren um das Bild zu sehen.



Na ja, mit der manuellen Regelung kann ich momentan gut leben und irgendwann werde ich auch wieder ein funktionierendes Steuergerät haben.

Dank der recht guten Informationen im WIS bin ich Momentan dabei mir das Steuergerät nachzubauen, vielleicht habe ich einen ersten Prototypen bis zum nächsten Schraubertreff ja fertig.

Gruß,
Ralf

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Quickbiker2012
  • Quickbiker2012s Avatar Autor
  • Offline
  • Senior
  • Senior
  • Americas (USA/CAN)
  • 560 SL 107.048 1987
Mehr
08 Jul 2021 01:39 #278793
von Quickbiker2012 Americas (USA/CAN) 560 SL 107.048 1987
Hallo Volker,

irgendwie hat sich der Titel des Themas von "560 SL - Leerlaufsteuergerät (N8) zeitweise ohne Funktion" auf "Schraubertreff Rhein-Main in Hanau" geändert. Kann man das wieder auf den originalen Titel zurück ändern?

Gruß,
Ralf

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Dr-DJet
  • Dr-DJets Avatar
  • Offline
  • Moderator
  • Moderator
  • Schweiz
  • 450 SL 107.044 1973
Mehr
08 Jul 2021 10:11 #278819
von Dr-DJet Schweiz 450 SL 107.044 1973
Hallo Ralf,

ich habe einen Verdacht, dass der Fehler an dem SMD Teil liegen könnte. Das habe ich auch schon im Klima Verstärker gehabt. Du müsstest mir Dein altes Steuergerät mal vorbei bringen.

Viele Schraubergrüße - best regards, Volker alias Dr-DJet und K-Jet Forscher, Admin und Betreiber dieser Webseite
Alles über D-Jetronic und Zündung auf jetronic.org

Dieses Bild ist für Gäste verborgen.
Bitte anmelden oder registrieren um das Bild zu sehen.


Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • PanTau
  • PanTaus Avatar
  • Offline
  • Elite
  • Elite
  • Standard (Europa)
  • 500 SLC 107.026 1980
Mehr
08 Jul 2021 10:40 #278823
von PanTau Standard (Europa) 500 SLC 107.026 1980

Hallo Frank,

ich nehme an, dass Du Dich am Wort Leerlaufsteller störst. Gemeint war die Ansteuerung des Leerlaufstellers bei defektem Leerlaufsteuergerät. Aber Du kennst sicherlich Ralfs Beitrag im Forum.

Immer noch neugierig, dann kann Ralf sicherlich weiterhelfen.

Gruß

Michael

Hallo Michael, 

aber da war keinerlei Ironie in meinen Worten oder Gedanken. Ich hatte gehofft, es gebe mittlerweile eine ertüftelte Lösung eines DIY-Steuergerätes, um den gebraucht  gut verfügbaren und fast nie defekten Leerlaufsteller des M102/M103 in meinen M117.960 adaptieren zu können.
Ich habe baujahrbedingt noch den rein mechanischen Zusatzluftschieber. 
Die "Zigarre" die dort ab 09/81 (M117.961) eingeführt wurde, wäre mir für eine Nachrüstung zu teuer und auch zu anfällig.
Nebenbei würde es mir sehr gefallen, für den Alltag und die Abgasuntersuchung den LL-Sollwert zwischen 500 und 750 Upm z. B. mit einem Poti verstellen zu können.
Das eigentliche Problem ist mein schwergängiger ZLS. 
Ich komme mit der Reparatur nicht weiter, weil ich keinen Gebrauchten bekomme. Mein jetziger arbeitet noch so la la, aber besser als nichts. Mit einer ordentlichen Dosis Ballistol in Durchflussrichtung konnte ich ihm wieder etwas Leben entlocken, aber mittelfristig muss da eine Lösung her. 
Also erneuere ich hier auch gleich meinen Aufruf: Wer hat einen defekten Zusatzluftschieber Bosch 0280140038 oder 0280140032 abzugeben?
Ziel ist die Erneuerung des Dehnstoffelements und die Anfertigung eines Halterings dafür. Wenn die Reparatur geglückt ist und die Maße dieses Halterings ermittelt sind, stelle ich diese selbstverständlich hier im Forum ein.

VG
Frank

VG
Frank

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Dr-DJet
  • Dr-DJets Avatar
  • Offline
  • Moderator
  • Moderator
  • Schweiz
  • 450 SL 107.044 1973
Mehr
08 Jul 2021 11:07 - 08 Jul 2021 11:14 #278827
von Dr-DJet Schweiz 450 SL 107.044 1973
Hallo Frank,

der Bosch Leerlaufsteller für M102 und M103 arbeitet ganz anders als die VDO Leerlaufsteller. Die haben z.B. eine Mindestöffnung und die öffnen unter Strom, während der VDO schließt. Die werden normalerweise aus dem KE Steuergerät heraus gesteuert. Natürlich könntest Du die manuelle Einstellmethode von Ralf verwenden.

Die Zusatzluftschieber gibt es schon noch und dann für richtig teuer Geld. Der 0280140038 ist übrigens verkehrt für den 380SL. Ein paar Anbieter überholen die auch. Ich habe das auch schon gemacht und habe eine Schublade voll von den ZLS. Das Einsprühen mit Balistol hilft normalerweise nichts, da das Dehnelement erlahmt und da Balistol auch keine Verkokung entfernt. Wenn Du umrüsten willst, solltest Du tatsächlich auf die VDO Leerlaufsteller umrüsten. Falls Ralf etwas entwickeln sollte, wird er ja keine Ansteuerung für den Bosch Leerlaufsteller bauen. Die Zigarren leiden auch unter der Verkokung. Die Bosch Leerlaufsteller habe ich immer für unkaputtbar gehalten. Bis ich kürzlich einem Kumpel an seinem 300 TE half. Da war der Leerlaufsteller defekt und der als Ersatz auf eBay beschaffte auch. Sauber waren sie und ich habe nicht heraus gefunden, warum die nicht richtig arbeiteten.

Viele Schraubergrüße - best regards, Volker alias Dr-DJet und K-Jet Forscher, Admin und Betreiber dieser Webseite
Alles über D-Jetronic und Zündung auf jetronic.org

Dieses Bild ist für Gäste verborgen.
Bitte anmelden oder registrieren um das Bild zu sehen.


Letzte Änderung: 08 Jul 2021 11:14 von Dr-DJet.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • PanTau
  • PanTaus Avatar
  • Offline
  • Elite
  • Elite
  • Standard (Europa)
  • 500 SLC 107.026 1980
Mehr
08 Jul 2021 11:24 #278829
von PanTau Standard (Europa) 500 SLC 107.026 1980
PanTau antwortete auf Schraubertreff Rhein-Main in Hanau
Hallo Volker, 

danke für die Infos mit der anderen Arbeitsweise! Ich denke aber das ist lösbar, denn das würde ja nur die Sollwertaufbereitung betreffen.
Ich würde eine Umrüstung auf elektronische Leerlaufregelung nur mit dem Bosch- Leerlaufsteller in Betracht ziehen und hier hatte ich auf eine erprobte Lösung gehofft. 
Mal gucken, ob ich da auf Arduino- Basis was hinbekomme. 
Für den Fall, dass ich mein Auto mal irgendwann verkaufe, muss ich trotzdem den Standard-ZLS repariert haben, daher betrachte ich beide Varianten.


 

VG
Frank

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Quickbiker2012
  • Quickbiker2012s Avatar Autor
  • Offline
  • Senior
  • Senior
  • Americas (USA/CAN)
  • 560 SL 107.048 1987
Mehr
08 Jul 2021 12:26 #278834
von Quickbiker2012 Americas (USA/CAN) 560 SL 107.048 1987
Quickbiker2012 antwortete auf Schraubertreff Rhein-Main in Hanau
Hallo Frank,

Wenn Du noch etwas Geduld hast, der Arduino liegt schon bei mir im Keller und das Steuerprogramm (PID Regler) habe ich rudimentär auch fertig. Bekomme die Tage noch ein paar Teile die ich brauche um es im Auto zu testen.... Momentan regelt er nur einen PC Lüfter mit Tachosignal.. Interessant wird dann sicher das Feintuning am Auto.

Mit Parametrisierung und Feintuning sollte sich das auf alle Leerlaufsteller anpassen lassen die mit PWM angesteuert werden können. Und dank USB ist das ja schnell gemacht bzw. Angepasst.

Gruss,
Ralf

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Quickbiker2012
  • Quickbiker2012s Avatar Autor
  • Offline
  • Senior
  • Senior
  • Americas (USA/CAN)
  • 560 SL 107.048 1987
Mehr
08 Jul 2021 12:33 #278837
von Quickbiker2012 Americas (USA/CAN) 560 SL 107.048 1987
Hallo Volker,

Ich bringe es am nächsten Schraubentreff mit, bis dahin brauche ich es noch für Vergleichsmessungen.

Da es momentan eh abgeklemmt ist und ich manuell regle hat das dann auch keine Eile.

Wäre auf jeden Fall schön wenn es wieder hinzubekommen wäre.

Gruss,
Ralf

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • PanTau
  • PanTaus Avatar
  • Offline
  • Elite
  • Elite
  • Standard (Europa)
  • 500 SLC 107.026 1980
Mehr
08 Jul 2021 14:01 #278845
von PanTau Standard (Europa) 500 SLC 107.026 1980
PanTau antwortete auf Schraubertreff Rhein-Main in Hanau
Hallo Ralf, 
prima! Sehr weit bin ich nämlich mit dem Arduino noch nicht gekommen, von ein paar Binärverknüpfungen mal abgesehen.
Ich interessiere mich besonders für Deine Endstufe, die den Strom an die Spule des Leerlaufstellers bereitstellt, und die PWM-Regulierung. 
Hast Du da Infos für mich?

 

VG
Frank

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Quickbiker2012
  • Quickbiker2012s Avatar Autor
  • Offline
  • Senior
  • Senior
  • Americas (USA/CAN)
  • 560 SL 107.048 1987
Mehr
08 Jul 2021 15:01 #278849
von Quickbiker2012 Americas (USA/CAN) 560 SL 107.048 1987
Hallo Frank,

vorgesehen habe ich momentan:

- Arduino Uno R3 (kann mit  bis zu 19V betrieben werden)
- Spannungsteiler aus 70 + 50 Ohm Widerstand (TD und Klimasignale etc. haben 12V)
- Zenerdiode 5,1 V parallel zum 50 Ohm Widerstand als Überspannungsschutz für die digitalen Eingänge des Arduino
- Folgenden PWM Verstärker (www.amazon.de/gp/product/B07VRCXGFY)
- Zweizeiliges LCD Display (1602A) zum Anzeigen der Drehzahl Soll/Ist und des PWM Verhältnisses
- Drehzahlmessung über den Timer 1 des Arduino (500ms Messinterval)
- Stellwertberechnung über eine PID Library alle 500ms und Anpassung des PWM Signals

Die im PWM verbauten MOSFET haben bereits eine eingebaute Löschdiode und können damit direkt angeschlossen werden. Getestet habe ich das an meinem Ersatz Löwe Steller - da hat das zusammen mit dem Arduino problemlos funktioniert.

Das ganze muss ich jetzt nur noch auf einer Prototypenplatine verlöten - momentan ist das alles auf einem Breadboard zusammengesteckt, und würde am lebenden Objekt nicht lange überleben :-)

Und dann mal sehen ob der Laboraufbau auch mit der Wirklichkeit zurechtkommt :-)

In weiteren Schritten sind dann die Drehzahlanpassung bei kaltem Motor, wenn Klima eingeschaltet wird (leichte Erhöhung) und die Absenkung wenn eine Fahrstufe eingelegt wurde. Das ist dann aber eher ein leichtes wenn die Regelung an sich funktioniert.

Gruß,
Ralf

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Quickbiker2012
  • Quickbiker2012s Avatar Autor
  • Offline
  • Senior
  • Senior
  • Americas (USA/CAN)
  • 560 SL 107.048 1987
Mehr
14 Jul 2021 12:31 #279192
von Quickbiker2012 Americas (USA/CAN) 560 SL 107.048 1987
Hallo Zusammen,

kurzes Update zum Projekt Leerlaufsteuergerät.

Nachdem ich den Prototypen am Montag aus der Laborumgebung am SL getestet hatte, trat etwas Ernüchterung ein. Egal wie ich die Regelparameter und Grenzen im Programm eingestellt habe, hat sich der Leerlauf früher oder später aufgeschaukelt und die acht Töpfe fingen mächtig an zu Sägen.

Also habe ich mir mit einem Ersatzsteller und dem originalen Steuergerät nochmal einen Teststand aufgebaut und die Ursache dank eines mittlerweile vernünftigen Oszilloskops gefunden. Der Leerlaufsteller wird nicht einfach nur mit einer per PWM gepulsten Gleichspannung angesteuert sondern mit einer pendelnden Spannung von +12V /  -12V. Wobei sich die -12 V nach kurzer Zeit wieder abbauen und wahrscheinlich dazu dienen das Magnetfeld im Steller abzubauen.

Mit dieser Art der Ansteuerung bewegt sich der Steller auch wesentlich gleichmäßiger. Im Testaufbau ruckte er auch ein wenig, und sowas ähnliches habe ich auch bei meinem manuellen Regler - das ist wohl auch der Grund für das Aufschaukeln des nachgebauten Reglers.

Also nächster Schritt dann doch mal das originale Steuergerät analysieren um zu sehen wie die negative Spannung erzeugt wird um das nachzubauen.

Keep you updated :-)

Gruß,
Ralf
Folgende Benutzer bedankten sich: PanTau, MartinG, ZitroniX

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Chromix
  • Chromixs Avatar
  • Offline
  • Premium
  • Premium
  • Americas (USA/CAN)
  • 560 SL 107.048 1986
  • Hofrat
Mehr
14 Jul 2021 20:28 #279219
von Chromix Americas (USA/CAN) 560 SL 107.048 1986
Hallo Ralf,

meinst Du nicht, daß die -12 V durch das Abschalten der Spule im LLS induziert werden? Müsste sich ja einfach feststellen lassen, wenn man das Ausgangssignal des Steuergerätes ohne angeschlossenen LLS misst.

Hälsningar,
Lutz

Alles ist noch niemals vorgekommen - bis es zum ersten Mal passiert.
Folgende Benutzer bedankten sich: Quickbiker2012

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Quickbiker2012
  • Quickbiker2012s Avatar Autor
  • Offline
  • Senior
  • Senior
  • Americas (USA/CAN)
  • 560 SL 107.048 1987
Mehr
15 Jul 2021 02:16 #279253
von Quickbiker2012 Americas (USA/CAN) 560 SL 107.048 1987
Hallo Lutz,

ja, in der tat werden die -12V vom LLS induziert. Ich war nur etwas irritiert da der negative Anteil auch eine ordentliche Rechteckform hatte. Ohne LLS oder mit einer ohmschen Last produziert das Steuergerät leider kein vernünftiges Signal zum Testen.

Da ich bei mir zusätzlich eine normale Freilaufdiode verbaut hatte wurde die Rückspannung quasi kurzgeschlossen, was wiederum das abbauen des Magnetfeldes verringerte.

Ich habe das heute mal mit einem normalen Hochspannungs MOSFET getestet - tatsächlich induziert der Leerlaufsteller -150 V 

Dieses Bild ist für Gäste verborgen.
Bitte anmelden oder registrieren um das Bild zu sehen.

wenn keine Freilaufdiode verbaut ist. Der PWM Steller den ich für den Arduino verwende sperrt zwar bei ~ 30V - der Rückstrom ist aber trotzdem hoch genug dass die Transistoren kochend heiß werden.

Werde mir die Tage mal ordentliche Z-Dioden und einen kleinen Vorwiderstand (1 Ohm, der ist auch im Steuergerät verbaut) besorgen um die Rückspannung auch bei 12V zu begrenzen

Danke fürs mitdenken :-)

Gruß,
Ralf
 

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Chromix
  • Chromixs Avatar
  • Offline
  • Premium
  • Premium
  • Americas (USA/CAN)
  • 560 SL 107.048 1986
  • Hofrat
Mehr
15 Jul 2021 08:08 #279260
von Chromix Americas (USA/CAN) 560 SL 107.048 1986
Hallo Ralf,

ich versuche mich derzeit gerade an einer Lüfternachlaufsteuerung für den Zusatzlüfter - ebenfalls mit PWM. Als Freilaufdiode habe ich eine Schottkydiode MBR2545 verbaut - das scheint ganz gut zu funktionieren. Für den MOSFET benutze ich einen speziellen Ansteuerbaustein, da die eingangsseitigen Kapazitäten schon ordentliche Stromspitzen beim Schalten verursachen. Ein normaler Transistor ist da leicht überfordert, der MOSFET schaltet nicht sauber und wird heiß.

Hälsningar,
Lutz

Alles ist noch niemals vorgekommen - bis es zum ersten Mal passiert.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Quickbiker2012
  • Quickbiker2012s Avatar Autor
  • Offline
  • Senior
  • Senior
  • Americas (USA/CAN)
  • 560 SL 107.048 1987
Mehr
26 Jul 2021 00:41 #280045
von Quickbiker2012 Americas (USA/CAN) 560 SL 107.048 1987
Hallo Zusammen,

ich bin jetzt wieder einen Schritt weiter (und nein, ich Stand vorher nicht am Abgrund 

Dieses Bild ist für Gäste verborgen.
Bitte anmelden oder registrieren um das Bild zu sehen.

)

Der Leistungsteil den sich VDO für den Leerlaufsteller ausgedacht hat weicht zumindest von den mir bekannten Implementationen für die Ansteuerung von Induktivitäten ab, wobei ich jetzt aber auch schon mehrere Jahre (wenn nicht Jahrzehnte) aus dem Business raus bin. Folgende Erkenntnisse habe ich jetzt:

- Die Rückspannung des LLS (Y6) kann nicht einfach mit einer Freilaufdiode "kurzgeschlossen" werden. Durch den dadurch recht hohen Strom bleibt das Magnetfeld im Steller erhalten und er lässt sich nicht ordentlich regeln, da er sich dann immer Ruckartig bewegt.
- Die Rückspannung des LLS nicht zu begrenzen führt zu einem zu schwachen Magnetfeld und damit auch zu einer nicht sauberen Verstellung. Mal abgesehen davon sind die recht hohen Spannungen (auch wenn man einen entsprechend Spannungsfesten Transistor einsetzt) immer eine Gefahr für die Elektronik
- Das begrenzen der Rückspannung auf ~ 13V (so ist es im originalen Steuergerät) durch eine Zenerdiode funktioniert nicht, da es die Diode zerbrutzelt. Durch die hohen Ströme von ~ 2A und die Impulsspitzen von 150V ist da einiges an Leistung zu verbraten (auch wenn es keine 300W sind wie die einfache Multiplikation ergeben würde), so wird eine Zenerdiode doch in extrem kurzer Zeit extrem heiß und ohne gut dimensionierte Kühlung ist der Exitus garantiert

Und wie hat VDO das gelöst? Einfach recht simpel - anstatt die Energie kurzzuschließen oder mit einer Z-Diode zu begrenzen wird diese in das Bordnetz abgeleitet. Dazu wird der LLS zweipolig abgeschaltet (also +12V und Masse) und die entstehende Rückspannung über zwei normale (aber ausreichend dimensionierte Dioden) an die Klemme 15 und 31 abgeleitet. Dadurch wird die Rückspannung auf die Bordspannung begrenzt - und das ist das was ich am Anfang irrtümlich als Wechselspannung interpretiert hatte.

Das habe ich nachgebaut (siehe Schaltplan) und das scheint auch zu funktionieren - die Transistoren werden nur Handwarm und der Steller bewegt sich ruckelfrei. Im Laufe der Woche wandert das als Prototyp ins Auto, mal gespannt wie es dann funktioniert. Wer das nachbauen und selber mal ausprobieren will - der 1 Ohm Widerstand und die beiden Dioden müssen einiges Aushalten - im kurzen Peak fällt über den Widerstand 3V ab - d.h. da fließen tatsächlich 3A Rückstrom. Deswegen habe ich auch 3A Dioden genommen (kleinere hätten es wahrscheinlich auch getan da es nur ein kurzer Peak von 3A ist. Von der Baugröße dürften im Originalen LLS 2A Exemplare verbaut sein. Die Dioden sind leider verlötet dass ich die Bezeichnung nicht lesen kann) und einen Widerstand mit 5W eingebaut. Der Widerstand zwar etwas mehr als Handwarm, ist aber weit weg von heiß und es entspricht auch in etwa der Wärmeentwicklung im originalen LLS.

Wenn der Leistungsteil dann auch im Fahrzeug funktioniert ist der Rest "nur" noch Programmieren - rudimentäre hatte der Arduino den Leerlauf ja schon gesteuert.

Gruß,
Ralf

Dieser Beitrag enthält einen Bildanhang.
Bitte anmelden (oder registrieren) um ihn zu sehen.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Quickbiker2012
  • Quickbiker2012s Avatar Autor
  • Offline
  • Senior
  • Senior
  • Americas (USA/CAN)
  • 560 SL 107.048 1987
Mehr
26 Jul 2021 00:48 #280046
von Quickbiker2012 Americas (USA/CAN) 560 SL 107.048 1987
Eine Ergänzung noch (leider kann ich den letzten Post nicht mehr bearbeiten):

Die von mir derzeit genutzte manuelle Regelung über einen PWM Steller hat prinzipiell das gleiche Problem - hier wird die Rückspannung kurzgeschlossen und der Steller bewegt sich etwas ruckelig.

Da man in dem Fall aber nichts regelt sondern nur ab und an mal was einstellt fällt das nicht wirklich negativ auf wenn sich der Leerlaufsteller mal ruckartig bewegt. Zumindest bei mir ist es so dass wenn man mal die Einstellung bei warmem Motor gefunden hat ändert man auch nichts mehr.

Gruß,
Ralf
Folgende Benutzer bedankten sich: citroen

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Chromix
  • Chromixs Avatar
  • Offline
  • Premium
  • Premium
  • Americas (USA/CAN)
  • 560 SL 107.048 1986
  • Hofrat
Mehr
27 Jul 2021 00:42 #280138
von Chromix Americas (USA/CAN) 560 SL 107.048 1986
Hallo Ralf,

interessante Problematik!
Warum bist Du von MOSFETs wieder abgekommen?
Und wozu dient der 1 Ohm Widerstand? Zur Begrenzung des Rückstroms? Und warum wurde er so dimensioniert?

Hälsningar,
Lutz

Alles ist noch niemals vorgekommen - bis es zum ersten Mal passiert.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Quickbiker2012
  • Quickbiker2012s Avatar Autor
  • Offline
  • Senior
  • Senior
  • Americas (USA/CAN)
  • 560 SL 107.048 1987
Mehr
27 Jul 2021 00:56 #280139
von Quickbiker2012 Americas (USA/CAN) 560 SL 107.048 1987
Hallo Lutz,

von den MOSFETs bin ich deswegen weil ich die Schaltung des originalen Steuergerätes nachbauen wollte um nachzuvollziehen was denn da genau passiert und wie das funktioniert.

Da die fertigen Module die ich gefunden bzw. vorrätig habe nur einpolig die Masse schalten war das damit nicht mehr zu realisieren. Abgesehen davon wollte ich jetzt erstmal was funktionierendes in der Hand haben um die Programmierung zu testen und zu finalisieren :-) Ob das final bei den normalen Transistoren bleibt weiß ich noch nicht, die Platine will ich (wenn alles funktioniert ohnehin) dann auch noch vernünftig Layouten und Ätzen lassen

Wegen dem 1 Ohm muss man VDO Fragen, den habe ich ebenso übernommen. Ich vermute aber auch dass er zur Strombegrenzung ist - zumindest für die Rückspannung scheint mir das Sinnvoll.

Gruß,
Ralf
Folgende Benutzer bedankten sich: Chromix

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Moderatoren: RagettiObelix116
Ladezeit der Seite: 0.103 Sekunden
Powered by Kunena Forum