× Welcome to our english Forum 107!

You may ask our experts anything around 107 SL and SLC and you will receive competent answers.

no coldstart 500 SL

  • lucwaignein
  • Topic Author
  • Offline
  • New Member
  • New Member
More
26 Nov 2022 21:05 #306714
no coldstart 500 SL was created by lucwaignein
Hallo,

My car has a difficult cold start, about 5 sec. cranking. Then drives well.
I also think the ECU is failing (no kick down etc)

Today impossible to start, what can be the reason?

Thanks, Luc
1987 500 SL no lambda

Please Log in or Create an account to join the conversation.

More
26 Nov 2022 22:00 #306716
Replied by Dr-DJet on topic no coldstart 500 SL
Hi Luc,

please check 2 things:
  1. Fuel pressure when cranking on flange to cold start valve
  2. Voltage on cold start valve while cranking

Viele Schraubergrüße - best regards, Volker alias Dr-DJet und K-Jet Forscher, Admin und Betreiber dieser Webseite
Alles über D-Jetronic und Zündung auf jetronic.org

This image is hidden for guests.
Please log in or register to see it.


Please Log in or Create an account to join the conversation.

  • lucwaignein
  • Topic Author
  • Offline
  • New Member
  • New Member
More
27 Nov 2022 10:03 #306725
Replied by lucwaignein on topic no coldstart 500 SL
Hi,

I checked voltage on cold start valve during cranking = OK
Also resistance on valve = OK (5 Ohm)
I can not check fuel pressure today.
(I can hear the fuel pumps running on ignition)

Thanks !
Luc

Please Log in or Create an account to join the conversation.

More
27 Nov 2022 12:54 #306735
Replied by Dr-DJet on topic no coldstart 500 SL
Hi Luc,

then I guess that you will see little or no fuel pressure. It might improve when you start ignition without starting engine several times before you finally crank it. If fuel pressure is bad, it can be

  1. Fuel accumulator
  2. Non-return valve on pump
  3. Leakage of fuel form fuel distributor to air flow sensor
  4. Leaking injectors
  5. Leaking cold start valve
  6. Leaking pressure regulator

Viele Schraubergrüße - best regards, Volker alias Dr-DJet und K-Jet Forscher, Admin und Betreiber dieser Webseite
Alles über D-Jetronic und Zündung auf jetronic.org

This image is hidden for guests.
Please log in or register to see it.


Please Log in or Create an account to join the conversation.

  • lucwaignein
  • Topic Author
  • Offline
  • New Member
  • New Member
More
03 Dec 2022 10:11 #307042
Replied by lucwaignein on topic no coldstart 500 SL
Hello,

I checked the fuel pressures and is OK, 5.5 bar at cranking, and after cranking stays at 3 bar. Engine is flooded immediately, spark plugs are wet.
Ignition is OK, I have sparks.
So I think : bad injectors or leaking cold start valve?

Please Log in or Create an account to join the conversation.

  • ZitroniX
  • ZitroniX's Avatar
  • Away
  • Premium Member
  • Premium Member
More
03 Dec 2022 10:19 - 03 Dec 2022 10:33 #307043
Replied by ZitroniX on topic no coldstart 500 SL
Good morning
change your plugs to Sparkplugs made by NGK
BOSCH plugs are made often in Russia and have problems

 

Alles könnte einfach sein, ist es aber nicht
R107 SL 380 (US) Bj 83, 930U silberblaumetallic

Gruss Andreas
Last edit: 03 Dec 2022 10:33 by ZitroniX.

Please Log in or Create an account to join the conversation.

More
03 Dec 2022 16:18 #307058
Replied by Dr-DJet on topic no coldstart 500 SL
Hi,

good hint from Andreas. If you have Bosch swap to NGK BP6ES.

If you have proper system pressure and holding pressure, points 1 and 2 are okay. Now open flap on air-flow sensor (after removing air filter) and light under fuel distributor. Is it wet there? Then remove thin hose on pressure regulator. Dry or fuel drops? If all that does fit, check injectors and cold start valve.

Viele Schraubergrüße - best regards, Volker alias Dr-DJet und K-Jet Forscher, Admin und Betreiber dieser Webseite
Alles über D-Jetronic und Zündung auf jetronic.org

This image is hidden for guests.
Please log in or register to see it.


Please Log in or Create an account to join the conversation.

Moderators: RagettiObelix116
Time to create page: 0.042 seconds
Powered by Kunena Forum